Patch release description

This document describes the content of the 4.0.x patch releases.

4.0.1

This fix was included in the version.

  • Token-userID mapping case sensitivity

    Using internal HSQLDB for token storage, this fix removed the requirement of userID case sensitivity (ie bob, bOb and BOB will now be accepted as userID to fetch the token). 

4.0.2

Fixes included in the version.

  • BankID proxy API

Solving error "loader constraint violation" when BankID proxy API and other outgoing http module(s), such as Freja eID or SAML Metadata loading from URL, are coexistent.


  • API Base handler

Solving error "Unable to parse http body into json"


  • Upgrade Easy Access


  • SAML Logout

Solving problem with logout fail.


  • SQL columns

Adding columns used by PAS to internal and external database


  • SQL name

Possible to change name of the external database


4.0.3

Fixes included in the version.

  • SAML Service Provider authenticator
    Solving problem with AuthN Request via Redirect / GET

  • VerifyJwtTokenValve
    Solving a problem with datatype conversion when verifying JWT

  • Password Reset Module
    Customizations might have to be re-implemented due to an updated dependency

4.0.4

Fix in this version

  • SAML authnReq with HTTP-Redirect binding.

Update of formatting when sending SAML authnReq with HTTP-Redirect binding.
Affects authNs OIDCToSAMLBroker and SAMLSPBroker.

4.0.5

Fix in this version

  • Password Reset Module
    Reverted back to original build for 4.0.x


  • Double encoding
    Solving a problem where of response data for GET requests were double encoded


  • SAML anonymous assignment
    Improved session handling


  • Improved loading of modules
    Solving problems with modules depending on the crypto module


 

Please contact PhenixID support for additional information.